Discussioni sul sistema operativo Linux
 

apache serve JS errati

g4b0 11 Set 2015 08:59
Ciao a tutti,
Ho una situazione particolare che mi sta facendo impazzire. Fedora 20
(non si può ne cambiare, ne aggiornare), apache, php in fast cgi e
compagnia cantante.

Ho un sito in ascolto sulla porta 80 e finchè ho sviluppato delle API in
PHP ha funzionato alla grande: riceve le richieste, elabora il tutto,
restituisce dei JSON.

Ho tirato su una piccola interfaccia grafica per testare le API,
utilizzando bootstrap, ed ha funzionato alla grande. Fin qui niente di
sistemistico.

Ad un certo punto mi sono messo a modificare il ******* main.js e sono
iniziate le rogne: apache serve sempre la stessa versione del ******* ma
della dimensione del ******* fisico. Esempio:

******* che serve apache:
alert('pippo');


Se io modifico il ******* in:
alert('pippo pluto');


Apache serve:
alert('pippo'); [con aggiunta di 6 null byte]


Se io modifico il ******* in
alert('pi');


Apache serve:
alert('pipp



Spero di essermi spiegato bene, in sostanza sembra che Apache si sia
cachato da qualche parte questo benedetto ******* js e continui a servirne
il contenuto cacheato, allineandolo però alla dimensione reale del *******
Ho provato a rinominare il ******* crearne uno nuovo, riavviato apache,
riavviato il server, ma niente.

A quanto pare apache si prende la prima versione di un qualsiasi ******* JS, e
non permette più di modificarlo!

La config di httpd è quella liscia di Fedora, io sono anni che lavoro
con Debian e non ho mai visto nulla di simile. Come la risolvo>

Garzie

P.S.
Scusate il post da google groups, ma nntp.aioe.org da ieri non risponde più...
Qualcuno sa il perchè?

--
g4b0, linux user n. 369000
http://brosulo.net
g4b0 14 Set 2015 09:06
On 11/09/2015 08:59, g4b0 wrote:
> Ciao a tutti,
> Ho una situazione particolare che mi sta facendo impazzire. Fedora 20
> (non si può ne cambiare, ne aggiornare), apache, php in fast cgi e
> compagnia cantante.

Ho risolto! Dimenticavo di dire che la macchina è virtualizzata su
Virtualbox e gestita tramite Vagrant. Il problema è un bug di virtualbox
vecchio di 8 anni :X

https://www.virtualbox.org/ticket/819

Mettendo *EnableMMAP off* nella config di apache ho risolto.

--
g4b0, linux user n. 369000
http://brosulo.net

Links
Giochi online
Dizionario sinonimi
Leggi e codici
Ricette
Testi
Webmatica
Hosting gratis
   
 

Discussioni sul sistema operativo Linux | Tutti i gruppi | it.comp.os.linux.sys | Notizie e discussioni linux | Linux Mobile | Servizio di consultazione news.